Issues Processing Credit Card Transactions

Minor incident Billing Legacy MCT
2021-07-26 12:00 NZDT · 3 hours, 1 minute, 1 second

Updates

Resolved

This issue is now resolved. Apologies for the disruption.

November 5, 2021 · 04:25 NZDT
Issue

Customers may be having issues processing Visa and MC transactions. We are working to resolve ASAP. Please contact support if you need help.

November 5, 2021 · 04:25 NZDT

← Back