Westpac Credit card payment failures

Minor incident Legacy MCT Billing
2020-05-12 10:09 NZDT · 3 hours, 54 minutes, 9 seconds

Updates

Resolved

We have been advised that Westpac’s processing issues are resolved.

May 12, 2020 · 14:04 NZDT
Issue

Our credit card processing partner have advised that some Credit Card payments from Westpac credit cards are failing. Westpac is investigating and working to resolve.

May 12, 2020 · 10:16 NZDT

← Back