Northland Power Outage

Major incident Priority Outages P2 Broadband Chorus North Power Mobile Voice Data Mobile Porting
2024-06-20 12:38 NZST · 20 hours, 19 minutes

Updates

Resolved

Power restored to the majority of Northland last evening so closing off this incident.

June 21, 2024 · 08:55 NZST
Monitoring

Northland Power Outage is ongoing and will continue to impact broadband and mobile services. Next update tomorrow.

June 20, 2024 · 17:37 NZST
Monitoring

Ongoing incident with power impacting a large part of Northland, this will have flow on effect to all services requiring power.

We will post further updates, intermittently as updates come from Power Companies.

June 20, 2024 · 12:38 NZST

← Back