Mobile Data Connectivity Issues

Major incident Priority Outages P2 Mobile Data
2025-02-23 17:22 NZDT · 15 minutes

Updates

Resolved

Engineers have identified root cause and implemented a fix. Some customers may need to toggle to airplane mode and back to resolve on their device.

February 23, 2025 · 17:35 NZDT
Issue

Engineers are investigating reports of issues with mobile data connectivity. More information to follow.

February 23, 2025 · 17:22 NZDT

← Back