Broadband Issues Palmerston North

Major incident Priority Outages P2 Broadband Chorus
2025-03-11 10:03 NZDT · 26 minutes

Updates

Monitoring

Upstream engineers have advised that service is fully restored and our monitoring shows most connections have reconnected. If your service is still down CPE may need a power cycle.

We will continue to monitor but please let us know if you are still experiencing issues.

March 11, 2025 · 10:47 NZDT
Investigating

Team are seeing connections coming back online. Please note some connections in areas outside of Palmerston North may have been impacted as well. Incident will remain open until upstream confirm resolution.

March 11, 2025 · 10:37 NZDT
Investigating

Incident has been isolated to backhaul network. Upstream engineers working to resolve.

March 11, 2025 · 10:08 NZDT
Issue

Engineers are investigating reports of broadband connectivity in Palmerston North.

March 11, 2025 · 10:03 NZDT

← Back