Issues with some International calling

Minor incident Voice International
2020-09-14 14:19 NZST · 33 minutes, 33 seconds

Updates

Resolved

Engineers have identified the problem and have now resolved. Any further issues please open a support ticket.

September 14, 2020 · 14:53 NZST
Issue

We are currently investigating reports of international calling issues. This appears to be impacting just some calls to some destinations. Further updates will follow.

September 14, 2020 · 14:22 NZST

← Back