Porting delays

Minor incident Voice Mobile Mobile Porting Local Porting
2025-10-17 09:44 NZDT · 2 days, 23 hours, 14 minutes

Updates

Resolved

All porting delays have been cleared. Closing

October 20, 2025 · 08:58 NZDT
Update

Seeing backlog clear now. Around 50% complete for outstanding.

October 17, 2025 · 15:42 NZDT
Issue

Industry wide delays with porting today - Local and Mobile.
Delays potentially up to 12 hours. Please follow for updates, thanks for your patience.

October 17, 2025 · 09:44 NZDT

← Back