Northpower Broadband Connections

Major incident Priority Outages P2 Broadband North Power
2025-11-19 10:38 NZDT · 36 minutes

Updates

Resolved

Services are stable so closing off this incident

November 19, 2025 · 11:14 NZDT
Monitoring

Engineers have identified the issue and implemented a fix. Sessions look healthy now and services should be back online. Engineers will continue to monitor health.

November 19, 2025 · 10:45 NZDT
Issue

Engineers are investigating an issue with Northpower broadband connections, more updates to follow.

November 19, 2025 · 10:38 NZDT

← Back