MCT Billing Issue

Minor incident Billing MCT
2020-11-05 11:05 NZST · 5 hours, 3 minutes, 36 seconds

Updates

Resolved

Confirming this issue was resolved earlier today.

November 5, 2020 · 16:08 NZST
Issue

Issue identified with MCT bill run last night. Team currently working to resolve.

November 5, 2020 · 11:06 NZST

← Back