Broadband Issues

Major incident Broadband Chorus Enable TFF North Power
2026-03-17 07:33 NZDT · 2 hours, 28 minutes

Updates

Resolved

Engineers are happy with service restoration.
Closing off incident.

Please reach out to Support Team if you are continuing to experience issues.

Thanks,

March 17, 2026 · 10:00 NZDT
Monitoring

Seeing Traffic on the handover now, issue appears to be resolved - Engineers are monitoring.

March 17, 2026 · 08:51 NZDT
Update

TFF Engineers are currently investigating the physicals. Thanks for your patience while they work hard to resolve.

March 17, 2026 · 08:35 NZDT
Update

Engineers have identified an issue with the TFF handover, which is currently producing errors. A fault has been logged with TF, and we’ll continue to monitor and provide updates as they come through.

Continue to follow for updates

March 17, 2026 · 08:16 NZDT
Investigating

Thanks for your patience. Engineers are still investigating the problem with the handover. Please continue to follow for updates.

March 17, 2026 · 07:59 NZDT
Investigating

Issue is related to the New Plymouth TFF HOL, no issues found on our side, we are working with upstream to investigate issues with backhaul and LFC.

March 17, 2026 · 07:42 NZDT
Issue

We’re getting reports of some connections offline this morning. The team are currently investigating. Please send examples of connections having issues to the support team for investigation.

March 17, 2026 · 07:33 NZDT

← Back