Broadband connections issues in Nelson region

Major incident Priority Outages P2 Broadband Chorus
2026-05-21 09:24 NZST · 2 hours, 33 minutes, 1 second

Updates

Monitoring

Engineers have identified the cause of the issue and have made a change to resolve.

Testing shows the change to be successful and engineers continue to monitor.

May 21, 2026 · 09:44 NZST
Issue

Engineers are currently investigating an issue affecting broadband connections in the Nelson region.

We will update here as more information becomes available.

May 21, 2026 · 09:24 NZST

← Back