MCT Billing Issue

Minor incident Billing MCT
2021-03-03 06:49 NZST · 9 hours, 59 minutes, 35 seconds

Updates

Resolved

Issue Resolve, Health checks were good. Will continue to monitor

March 3, 2021 · 16:49 NZST
Monitoring

Issue resolved, working through tidy up and health checks

March 3, 2021 · 10:48 NZST
Investigating

Investigating MCT Billing Issue

March 3, 2021 · 06:51 NZST

← Back