Internet Performance Issues

Major incident Broadband Chorus Enable UFF North Power
2021-05-18 08:40 NZST · 34 minutes, 5 seconds

Updates

Resolved

Engineers have identified the issue and applied a fix to resolve. Customers are reporting issues are now fixed. Any further issues please contact our support.

May 18, 2021 · 09:14 NZST
Issue

Reports of internet performance issues this morning. Engineers are currently investigating and we will provide an update ASAP.

May 18, 2021 · 08:43 NZST

← Back