Auckland CBD Fire Impact

Minor incident Support
2019-10-23 08:29 NZDT · 6 days, 8 hours, 5 minutes, 39 seconds

Updates

Resolved

As of today all 2talk staff are back in the office as per normal.

October 29, 2019 · 16:35 NZDT
Issue

With the disruption in the city and health warnings due to smoke inhalation 2talk have asked staff to work from home today. Please use tickets and web chat as the primary method to contact the team as we will have limited phone support.

October 23, 2019 · 08:37 NZDT

← Back