Billing Issues

Minor incident Billing MCT
2022-03-01 09:06 NZST · 4 hours, 26 minutes, 30 seconds

Updates

Resolved

All call data should now be available in the web portal.

March 1, 2022 · 13:33 NZST
Investigating

Some customers are still unable to access last months calls as process is taking longer than expected to complete. We will post again once it has completed.

March 1, 2022 · 12:21 NZST
Update

Developers are working through steps to resolve issue and expect to complete by midday. Invoices are now being delivered, some customers currently are unable to access last month’s call records.

March 1, 2022 · 10:24 NZST
Issue

There were issues with the MCT Bill Run overnight and some customers will not be able to access invoices or will have inconsistent balance displays. Developers are working to fix asap.

March 1, 2022 · 09:10 NZST

← Back