Fire alarm at 2talk office

Minor incident Support
2020-02-18 12:00 NZST · 51 minutes, 16 seconds

Updates

Resolved

Building has been cleared by fire brigade. Staff have resumed answering support enquiries.

February 18, 2020 · 12:51 NZST
Investigating

Currently fire alarm at 2talk office. Support staff evacuated so there will be delays answering support queries.

February 18, 2020 · 12:01 NZST

← Back