Calling issues in Blenheim

Minor incident Voice National
2022-06-15 13:16 NZST · 3 hours, 15 minutes, 35 seconds

Updates

Resolved

Engineers upstream have resolved the calling issue in Blenheim.

June 15, 2022 · 16:31 NZST
Issue

Problems with calling in Blenheim. This is related to an issue upstream. Engineers are investigating and working on a fix.

June 15, 2022 · 13:38 NZST

← Back